MySQL 4.1 install

Railsのマイグレーションを実行したところ、UTF8関連のエラーが発生。
調べてみたところ、MySQL 4.1以上を入れる必要があるらしい。
情報元 忘れたときに備えた記録 – MySQL の encoding 設定 , MySQL の encoding 設定 (2) , Amazonの規約 , Amazon始めました , MySQL の encoding 設定 (3)

$ apt-get install mysql-server-4.1


文字コード設定を/etc/mysql/my.cnfに追加。

[mysqld]
default-character-set = utf8
[mysql]
default-character-set = utf8
[mysqldump]
default-character-set = utf8


再起動。

# /etc/init.d/mysql restart

シェアする

  • このエントリーをはてなブックマークに追加

フォローする